ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/deliantra/server/debian/patches/20_helppickup.dpatch
Revision: 1.1
Committed: Fri Feb 3 07:11:47 2006 UTC (18 years, 4 months ago) by root
Branch point for: UPSTREAM, MAIN
Log Message:
Initial revision

File Contents

# User Rev Content
1 root 1.1 #!/bin/sh -e
2     ## 20_helppickup.dpatch by <tanner@debian>
3     ##
4     ## All lines beginning with `## DP:' are a description of the patch.
5     ## DP: No description.
6    
7     if [ $# -lt 1 ]; then
8     echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9     exit 1
10     fi
11    
12     [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13     patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
14    
15     case "$1" in
16     -patch) patch $patch_opts -p1 < $0;;
17     -unpatch) patch $patch_opts -p1 -R < $0;;
18     *)
19     echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
20     exit 1;;
21     esac
22    
23     exit 0
24    
25     @DPATCH@
26     diff -urNad /home/tanner/projects/crossfire/crossfire-snapshot/lib/help/pickup crossfire-snapshot/lib/help/pickup
27     --- /home/tanner/projects/crossfire/crossfire-snapshot/lib/help/pickup 1999-04-02 13:10:08.000000000 -0600
28     +++ crossfire-snapshot/lib/help/pickup 2004-02-04 23:02:23.000000000 -0600
29     @@ -1,17 +1,18 @@
30     'pickup' changes how you pick up items when you step on them.
31     to pickup an item manually, use the ',' key.
32    
33     -Mode 0: Don't pick up items.
34     -Mode 1: Pick up one item
35     -Mode 2: Pickup up one item and stop
36     -Mode 3: Stop before picking up items
37     -Mode 4: Pick up all items
38     -Mode 5: Pick up all items and stop
39     -Mode 6: Pick up all magical items
40     -Mode 7: Pick up all coins and gems
41     +Flag all: Pickup all items.
42     +Flag none: Don't pick up items.
43     +Flag ammo: Pickup arrows and bolts.
44     +Flag equip: Pickup containers, keys, lighters.
45     +Flag armor: Pickup up armor, shiels, helmets, shoes and cloths.
46     +Flag weapons: Pickup blades, bows, and other weapons.
47     +Flag magic: Pickup all magical items
48     +Flag food: Pickup food and drink. Includes poisons.
49     +Flag money: Pickup coins and gems
50    
51     -Modes above 7: Pickup items with
52     -a value density greater than the pickup mode.
53     +Flag density n: Pickup items with a value density
54     +density greater than 'n'.
55    
56     Value density is value in gold/weight in kilograms.
57