ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/gvpe/debian/rules
Revision: 1.1
Committed: Mon Mar 10 13:29:07 2003 UTC (21 years, 3 months ago) by Arvoreen
Branch: MAIN
Log Message:
*** empty log message ***

File Contents

# User Rev Content
1 Arvoreen 1.1 #!/usr/bin/make -f
2     # Sample debian/rules that uses debhelper.
3     # GNU copyright 1997 to 1999 by Joey Hess.
4    
5     # Uncomment this to turn on verbose mode.
6     #export DH_VERBOSE=1
7    
8     # This is the debhelper compatability version to use.
9     export DH_COMPAT=3
10    
11     ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
12     CFLAGS += -g3 -O0 -fno-inline
13     LDFLAGS += -g3
14     else
15     CFLAGS += -g -O2
16     LDFLAGS += -g
17     endif
18    
19     ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
20     STRIP = yes
21     endif
22    
23    
24     build: build-stamp
25     build-stamp:
26     dh_testdir
27    
28     # # If the Makefile.in.in file in po/ already contains DESTDIR support, skip the patching.
29     cd `pwd`/po ; ( \
30     if ! grep DESTDIR Makefile.in.in > /dev/null ; then \
31     patch -Ns -p0 < `pwd`/../debian/po-Makefile.in.in.diff || true ;\
32     fi ;\
33     )
34     CC=gcc-2.95 CPP=cpp-2.95 ./configure --prefix=/usr --mandir=\$${prefix}/share/man \
35     --infodir=\$${prefix}/share/info --sysconfdir=/etc \
36     --localstatedir=/var --enable-hmac-length=4 --enable-trust \
37     --enable-rand-length=0 --enable-cipher=bf --enable-digest=md4
38     $(MAKE)
39     # cd doc && texi2html -split=chapter tinc.texi
40    
41     touch build-stamp
42    
43     clean:
44     dh_testdir
45     dh_testroot
46     rm -f build-stamp
47    
48     -$(MAKE) distclean
49    
50     dh_clean
51    
52     install: build
53     dh_testdir
54     dh_testroot
55     dh_clean -k
56     dh_installdirs
57    
58     $(MAKE) install DESTDIR=`pwd`/debian/tmp
59    
60     # Build architecture-independent files here.
61     binary-indep: build install
62     # We have nothing to do by default.
63    
64     # Build architecture-dependent files here.
65     binary-arch: build install
66     dh_testdir
67     dh_testroot
68     #dh_movefiles
69     #install -o root -g root -m 755 debian/init.d debian/tinc/etc/init.d/tinc
70     dh_installmanpages
71     dh_installinfo
72     dh_installchangelogs ChangeLog
73     dh_link
74     @ if [ "$(STRIP)" = "yes" ] ; then \
75     dh_strip ;\
76     fi
77     dh_compress
78     dh_fixperms
79     dh_installdeb
80     dh_shlibdeps
81     dh_gencontrol
82     dh_md5sums
83     dh_builddeb
84    
85     binary: binary-indep binary-arch
86     .PHONY: build clean binary-indep binary-arch binary install