ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/cvsroot/apache2-frontend/apache2.conf
Revision: 1.3
Committed: Thu Jun 18 16:35:01 2015 UTC (11 years, 3 months ago) by root
Branch: MAIN
Changes since 1.2: +1 -1 lines
Log Message:
*** empty log message ***

File Contents

# Content
1 # apache2 -X -d /etc/frontend -e debug
2
3 # apt-get install apache2 libapache2-mod-perl2 libdata-dump-perl libcommon-sense-perl
4
5 #ServerRoot "/dev/null"
6 Mutex pthread default
7 PidFile /run/frontend.pid
8
9 Timeout 60
10 KeepAlive On
11 MaxKeepAliveRequests 100
12 KeepAliveTimeout 30
13
14 User www-data
15 Group www-data
16
17 HostnameLookups Off
18
19 # LogLevel: Control the severity of messages logged to the error_log.
20 # Available values: trace8, ..., trace1, debug, info, notice, warn,
21 # error, crit, alert, emerg.
22 # It is also possible to configure the log level for particular modules, e.g.
23 # "LogLevel info ssl:warn"
24 #
25 LogLevel warn
26
27 LoadModule mpm_event_module /usr/lib/apache2/modules/mod_mpm_event.so
28 LoadModule authz_core_module /usr/lib/apache2/modules/mod_authz_core.so
29 LoadModule cgi_module /usr/lib/apache2/modules/mod_cgi.so
30
31 LoadModule mime_module /usr/lib/apache2/modules/mod_mime.so
32 TypesConfig /etc/mime.types
33
34 # must not be loaded
35 #LoadModule dir_module /usr/lib/apache2/modules/mod_dir.so
36 #DirectoryIndex index.html
37
38 LoadModule autoindex_module /usr/lib/apache2/modules/mod_autoindex.so
39 IndexOptions Charset=UTF-8 FancyIndexing FoldersFirst HTMLTable SuppressColumnSorting
40 HeaderName HEADER.html
41 ReadmeName FOOTER.html
42
43 LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
44 #LoadModule proxy_fcgi_module /usr/lib/apache2/modules/mod_proxy_fcgi.so
45
46 LoadModule proxy_scgi_module /usr/lib/apache2/modules/mod_proxy_scgi.so
47 #ProxySCGIInternalRedirect Internal-Redirect apache 2.6 :/
48 ProxySCGIInternalRedirect On
49 ProxySCGISendfile On
50
51 #LoadModule proxy_fdpass_module /usr/lib/apache2/modules/mod_proxy_fdpass.so
52 LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
53 LoadModule xml2enc_module /usr/lib/apache2/modules/mod_xml2enc.so
54 LoadModule deflate_module /usr/lib/apache2/modules/mod_deflate.so
55 LoadModule proxy_html_module /usr/lib/apache2/modules/mod_proxy_html.so
56
57 LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
58
59 # Sets the default security model of the Apache2 HTTPD server. It does
60 # not allow access to the root filesystem outside of /usr/share and /var/www.
61 # The former is used by web applications packaged in Debian,
62 # the latter may be used for local directories served by the web server. If
63 # your system is serving content from a sub-directory in /srv you must allow
64 # access here, or in any related virtual host.
65 <Directory />
66 Options FollowSymLinks
67 AllowOverride None
68 Require all denied
69 </Directory>
70
71 <Directory /var/www/>
72 Options Indexes FollowSymLinks
73 Require all granted
74 </Directory>
75
76 AccessFileName .htaccess
77
78 #
79 # The following lines prevent .htaccess and .htpasswd files from being
80 # viewed by Web clients.
81 #
82 <FilesMatch "^\.ht">
83 Require all denied
84 </FilesMatch>
85
86 LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\" %{Host}i" schmorp
87 LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
88 LogFormat "%h %l %u %t \"%r\" %>s %O" common
89 LogFormat "%{Referer}i -> %U" referer
90 LogFormat "%{User-agent}i" agent
91
92 CustomLog /var/log/frontend/access.log schmorp
93 ErrorLog /var/log/frontend/error.log
94
95 ServerLimit 1
96 MaxClients 100
97 MaxRequestWorkers 100
98 StartServers 1
99 ThreadsPerChild 100
100 ThreadLimit 200
101 MinSpareThreads 6
102 MaxSpareThreads 16
103
104 MaxMemFree 64
105 #ThreadStackSize 65536 # basically gets ignored
106
107 PerlInterpStart 1
108 PerlInterpMax 1
109 PerlInterpMinSpare 0
110 PerlInterpMaxSpare 1
111 PerlInterpScope Handler
112
113 Include proxy_html.conf
114
115 # for debugging, enable reverse proxy url rewrite logging
116 #LogLevel warn proxy_html:trace3
117
118 ProxyHTMLDocType "<!DOCTYPE html>" SGML
119 ProxyHTMLExtended on
120
121 # mod_proxy_html uncompresses content, but doesn't recompress nor remove
122 # content-encoding header
123 SetOutputFilter INFLATE;DEFLATE
124
125 <Perl>
126 use Apache2::ServerUtil ();
127 use Apache2::Const -compile => qw(OK);
128 use lib Apache2::ServerUtil::server_root;
129 use proxy_impl;
130 </Perl>
131
132 PerlOptions None +Trans +MapToStorage +HeaderParser +Authen +Authz +Type
133
134 PerlTransHandler Apache2::Const::OK
135 PerlMapToStorageHandler proxy_impl::map_to_storage
136 PerlHeaderParserHandler Apache2::Const::OK
137 #PerlAccessHandler Apache2::Const::OK
138 PerlAuthenHandler Apache2::Const::OK
139 PerlAuthzHandler Apache2::Const::OK
140 #PerlTypeHandler Apache2::Const::OK
141 #PerlFixupHandler Apache2::Const::OK
142
143 # handlers run anyway
144 # fixup mod_proxy checks for proxy: handler strings
145 # fixup mod_ssl annotates with lots of ssl, or updates for ssl optional
146 # type mod_mime does its job
147
148 # RUN_FIRST translate_name
149 # RUN_FIRST map_to_storage
150 # RUN_FIRST check_user_id
151 # RUN_ALL fixups
152 # RUN_FIRST type_checker
153 # RUN_ALL access_checker
154 # RUN_FIRST access_checker_ex
155 # RUN_FIRST auth_checker
156 # VOID insert_filter
157 # RUN_ALL create_request
158 # RUN_ALL post_perdir_config
159 # RUN_FIRST dirwalk_stat
160
161 # mod_dir fixup
162 # mod_cgi response
163 # mod_autoindex response
164 # ap_process_request_internal() function in server/request.c
165
166 <Location />
167 Options Indexes FollowSymLinks
168 Require all granted
169 </Location>
170
171 Include local.conf
172
173 # vim: syntax=apache ts=8 sw=4
174