ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/cvsroot/apache2-frontend/apache2.conf
Revision: 1.8
Committed: Fri Jun 19 08:42:27 2015 UTC (11 years, 3 months ago) by root
Branch: MAIN
Changes since 1.7: +1 -0 lines
Log Message:
*** empty log message ***

File Contents

# Content
1 # apache2 -X -d /etc/frontend -e debug
2
3 # apt-get install apache2 libapache2-mod-perl2 libdata-dump-perl libcommon-sense-perl
4
5 #ServerRoot "/dev/null"
6 Mutex pthread default
7 PidFile /run/frontend.pid
8
9 Timeout 60
10 KeepAlive On
11 MaxKeepAliveRequests 100
12 KeepAliveTimeout 30
13
14 User www-data
15 Group www-data
16
17 HostnameLookups Off
18
19 AddDefaultCharset UTF-8
20
21 # LogLevel: Control the severity of messages logged to the error_log.
22 # Available values: trace8, ..., trace1, debug, info, notice, warn,
23 # error, crit, alert, emerg.
24 # It is also possible to configure the log level for particular modules, e.g.
25 # "LogLevel info ssl:warn"
26 #
27 LogLevel warn
28
29 LoadModule mpm_event_module /usr/lib/apache2/modules/mod_mpm_event.so
30 LoadModule authz_core_module /usr/lib/apache2/modules/mod_authz_core.so
31 LoadModule cgi_module /usr/lib/apache2/modules/mod_cgi.so
32
33 LoadModule mime_module /usr/lib/apache2/modules/mod_mime.so
34 TypesConfig /etc/mime.types
35 LoadModule mime_magic_module /usr/lib/apache2/modules/mod_mime_magic.so
36 MIMEMagicFile /etc/apache2/magic
37
38 # must not be loaded
39 #LoadModule dir_module /usr/lib/apache2/modules/mod_dir.so
40 #DirectoryIndex index.html
41
42 LoadModule autoindex_module /usr/lib/apache2/modules/mod_autoindex.so
43 IndexOptions Charset=UTF-8 FancyIndexing FoldersFirst HTMLTable SuppressColumnSorting
44 HeaderName HEADER.html
45 ReadmeName FOOTER.html
46
47 LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
48 #LoadModule proxy_fcgi_module /usr/lib/apache2/modules/mod_proxy_fcgi.so
49
50 LoadModule proxy_scgi_module /usr/lib/apache2/modules/mod_proxy_scgi.so
51 #ProxySCGIInternalRedirect Internal-Redirect apache 2.6 :/
52 ProxySCGIInternalRedirect On
53 ProxySCGISendfile On
54
55 #LoadModule proxy_fdpass_module /usr/lib/apache2/modules/mod_proxy_fdpass.so
56 LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so
57 LoadModule xml2enc_module /usr/lib/apache2/modules/mod_xml2enc.so
58 LoadModule deflate_module /usr/lib/apache2/modules/mod_deflate.so
59 LoadModule proxy_html_module /usr/lib/apache2/modules/mod_proxy_html.so
60
61 LoadModule perl_module /usr/lib/apache2/modules/mod_perl.so
62
63 # Sets the default security model of the Apache2 HTTPD server. It does
64 # not allow access to the root filesystem outside of /usr/share and /var/www.
65 # The former is used by web applications packaged in Debian,
66 # the latter may be used for local directories served by the web server. If
67 # your system is serving content from a sub-directory in /srv you must allow
68 # access here, or in any related virtual host.
69 <Directory />
70 Options FollowSymLinks
71 AllowOverride None
72 Require all denied
73 </Directory>
74
75 <Directory /var/www/>
76 Options Indexes FollowSymLinks
77 Require all granted
78 </Directory>
79
80 AccessFileName .htaccess
81
82 #
83 # The following lines prevent .htaccess and .htpasswd files from being
84 # viewed by Web clients.
85 #
86 <FilesMatch "^\.ht">
87 Require all denied
88 </FilesMatch>
89
90 LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\" %{Host}i" schmorp
91 LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
92 LogFormat "%h %l %u %t \"%r\" %>s %O" common
93 LogFormat "%{Referer}i -> %U" referer
94 LogFormat "%{User-agent}i" agent
95
96 CustomLog /var/log/frontend/access.log schmorp
97 ErrorLog /var/log/frontend/error.log
98
99 ServerLimit 1
100 MaxClients 100
101 MaxRequestWorkers 100
102 StartServers 1
103 ThreadsPerChild 100
104 ThreadLimit 200
105 MinSpareThreads 6
106 MaxSpareThreads 16
107
108 MaxMemFree 64
109 #ThreadStackSize 65536 # basically gets ignored
110
111 PerlInterpStart 1
112 PerlInterpMax 1
113 PerlInterpMinSpare 0
114 PerlInterpMaxSpare 1
115 PerlInterpScope Handler
116
117 Include proxy_html.conf
118
119 # for debugging, enable reverse proxy url rewrite logging
120 #LogLevel warn proxy_html:trace3
121
122 ProxyHTMLDocType "<!DOCTYPE html>" SGML
123 ProxyHTMLExtended on
124
125 # mod_proxy_html uncompresses content, but doesn't recompress nor remove
126 # content-encoding header
127 SetOutputFilter INFLATE;DEFLATE
128
129 <Perl>
130 use Apache2::ServerUtil ();
131 use Apache2::Const -compile => qw(OK);
132 use lib Apache2::ServerUtil::server_root;
133 use proxy_impl;
134 </Perl>
135
136 PerlOptions None +Trans +MapToStorage +HeaderParser +Authen +Authz +Type
137
138 PerlTransHandler Apache2::Const::OK
139 PerlMapToStorageHandler proxy_impl::map_to_storage
140 PerlHeaderParserHandler Apache2::Const::OK
141 #PerlAccessHandler Apache2::Const::OK
142 PerlAuthenHandler Apache2::Const::OK
143 PerlAuthzHandler Apache2::Const::OK
144 #PerlTypeHandler Apache2::Const::OK
145 #PerlFixupHandler Apache2::Const::OK
146
147 # handlers run anyway
148 # fixup mod_proxy checks for proxy: handler strings
149 # fixup mod_ssl annotates with lots of ssl, or updates for ssl optional
150 # type mod_mime mod_mime_magic do their job
151
152 # RUN_FIRST translate_name
153 # RUN_FIRST map_to_storage
154 # RUN_FIRST check_user_id
155 # RUN_ALL fixups
156 # RUN_FIRST type_checker
157 # RUN_ALL access_checker
158 # RUN_FIRST access_checker_ex
159 # RUN_FIRST auth_checker
160 # VOID insert_filter
161 # RUN_ALL create_request
162 # RUN_ALL post_perdir_config
163 # RUN_FIRST dirwalk_stat
164
165 # mod_dir fixup
166 # mod_cgi response
167 # mod_autoindex response
168 # ap_process_request_internal() function in server/request.c
169
170 <Location />
171 Options Indexes FollowSymLinks
172 Require all granted
173 </Location>
174
175 Include local.conf
176
177 # vim: syntax=apache ts=8 sw=4
178