ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/deliantra/server/debian/crossfire-server.postinst
Revision: 1.2
Committed: Tue Feb 27 12:06:08 2007 UTC (17 years, 2 months ago) by pippijn
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +0 -0 lines
State: FILE REMOVED
Log Message:
renamed crossfire to cfplus

File Contents

# User Rev Content
1 root 1.1 #! /bin/sh -e
2    
3     . /usr/share/debconf/confmodule
4    
5     case "$1" in
6     configure)
7     #remove world writable bits from files in /var/games/crossfire. These
8     #are left from old packages
9     if [ -d /var/games/crossfire/ ]; then
10     if [ "`find /var/games/crossfire/ -type f -perm 0666 | wc -l`" -gt 0 ]; then
11     echo "removing world writable bits from crossfire files in /var/games/crossfire/"
12     find /var/games/crossfire/ -type f -perm 0666 |xargs chmod o-w
13     fi
14     fi
15    
16     #pre-1.0.0 versions may have left world writable logfiles
17     if [ -d /var/log/crossfire/ ]; then
18     if [ "`find /var/log/crossfire/ -type f -perm 0666 | wc -l`" -gt 0 ]; then
19     echo "removing world writable bits from crossfire log files in /var/log/crossfire/"
20     find /var/log/crossfire/ -type f -perm 0666 |xargs chmod o-w
21     fi
22     fi
23     ;;
24    
25     abort-upgrade)
26     # do nothing
27     ;;
28    
29     abort-remove)
30     # do nothing
31     ;;
32    
33     abort-deconfigure)
34     # do nothing
35     ;;
36    
37     *)
38     echo "$0: incorrect arguments: $*" >&2
39     exit 1
40     ;;
41    
42     esac
43    
44     #crossfire seems to be buggy regarding fd handling, FIXME!
45     db_stop || true
46    
47     #DEBHELPER#
48