ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/deliantra/server/debian/patches/10_initsettings.dpatch
Revision: 1.1
Committed: Fri Feb 3 07:11:47 2006 UTC (18 years, 4 months ago) by root
Branch point for: UPSTREAM, MAIN
Log Message:
Initial revision

File Contents

# User Rev Content
1 root 1.1 #!/bin/sh -e
2     ## 10_initsettings.dpatch by <tanner@debian>
3     ##
4     ## All lines beginning with `## DP:' are a description of the patch.
5     ## DP: No description.
6    
7     if [ $# -lt 1 ]; then
8     echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9     exit 1
10     fi
11    
12     [ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13     patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
14    
15     case "$1" in
16     -patch) patch $patch_opts -p1 < $0;;
17     -unpatch) patch $patch_opts -p1 -R < $0;;
18     *)
19     echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
20     exit 1;;
21     esac
22    
23     exit 0
24    
25     @DPATCH@
26     diff -urNad /home/tanner/projects/crossfire/crossfire-snapshot/common/init.c crossfire-snapshot/common/init.c
27     --- /home/tanner/projects/crossfire/crossfire-snapshot/common/init.c 2003-09-13 00:01:27.000000000 -0500
28     +++ crossfire-snapshot/common/init.c 2004-02-04 22:59:06.000000000 -0600
29     @@ -35,7 +35,7 @@
30     * correspond to.
31     */
32     struct Settings settings = {
33     -"", /* Logfile */
34     +"/var/log/crossfire/logfile", /* Logfile */
35     CSPORT, /* Client/server port */
36    
37     /* Debug level */