ViewVC Help
View File | Revision Log | Show Annotations | Download File
/cvs/deliantra/server/debian/rules
Revision: 1.2
Committed: Tue Feb 27 11:58:40 2007 UTC (17 years, 3 months ago) by pippijn
Branch: MAIN
CVS Tags: rel-2_82, rel-2_81, rel-2_80, rel-3_1, rel-3_0, rel-2_6, rel-2_7, rel-2_4, rel-2_5, rel-2_2, rel-2_3, rel-2_0, rel-2_1, rel-2_72, rel-2_73, rel-2_71, rel-2_76, rel-2_77, rel-2_74, rel-2_75, rel-2_54, rel-2_55, rel-2_56, rel-2_79, rel-2_52, rel-2_53, rel-2_32, rel-2_90, rel-2_92, rel-2_93, rel-2_78, rel-2_61, rel-2_43, rel-2_42, rel-2_41, HEAD
Changes since 1.1: +9 -17 lines
Log Message:
started debian package.. still incomplete (e.g. ext, doc, ..)

File Contents

# User Rev Content
1 root 1.1 #!/usr/bin/make -f
2    
3     # Uncomment this to turn on verbose mode.
4     export DH_VERBOSE=1
5    
6 pippijn 1.2 MAKE=make -j5
7    
8 root 1.1 LIB_DIR = var/games/crossfire
9     DATADIR = usr/share/games/crossfire
10    
11     build: patch build-stamp
12     build-stamp:
13     dh_testdir
14    
15     # What max debug info, so turn it on
16     CFLAGS="-g3" \
17 pippijn 1.2 sh autogen.sh --prefix=/$(LIB_DIR) \
18 root 1.1 --datadir=/usr/share/games \
19     --bindir=/usr/games \
20     --mandir=/usr/share/man \
21     --localstatedir=/var/games \
22     --sysconfdir=/etc
23    
24     # Add here commands to compile the package.
25     $(MAKE) all
26    
27     touch build-stamp
28    
29     clean: clean-patched unpatch
30    
31     clean-patched:
32     dh_testdir
33     dh_testroot
34     -rm -f build-stamp
35     -rm -f install-stamp
36 pippijn 1.2 -rm -rf debian/cfplus-server
37 root 1.1
38     # Add here commands to clean up after the build process.
39     -$(MAKE) distclean
40    
41     dh_clean
42    
43     patch: patch-stamp
44     patch-stamp:
45     dpatch apply-all --verbose
46     touch patch-stamp
47    
48     unpatch:
49     dpatch deapply-all --verbose
50     rm -rf patch-stamp debian/patched
51    
52     install: binary-indep binary-arch
53    
54     # Build architecture-independent files here.
55     binary-indep:
56     dh_testdir
57     dh_testroot
58     dh_clean -k -i
59     dh_installdirs -i
60    
61     cd lib && \
62     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
63    
64     cd lib && \
65     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
66    
67     cd utils && \
68     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
69    
70     # Clean up some
71     -rm -f $(CURDIR)/debian/tmp/usr/games/crossloop.pl
72     -rm -f $(CURDIR)/debian/tmp/usr/games/player_dl.pl
73    
74 pippijn 1.2 #cd doc && \
75     #$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
76 root 1.1
77 pippijn 1.2 #dh_installdocs -A
78     #dh_installdocs -pcfplus-doc
79 root 1.1 dh_install -i
80    
81     # Build architecture-dependent files here.
82     binary-arch:
83     dh_testdir
84     dh_testroot
85     dh_installchangelogs
86    
87     cd random_maps && \
88     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
89    
90     cd server && \
91     $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
92    
93     dh_installlogrotate
94     dh_installinit -r -- defaults 99 01
95     dh_installman
96 pippijn 1.2 dh_strip --dbg-package=cfplus-server
97 root 1.1 dh_compress
98     dh_fixperms
99     dh_makeshlibs -V
100     dh_installdeb
101     dh_gencontrol
102     dh_md5sums
103     dh_builddeb
104    
105     source diff:
106     @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
107    
108     binary: binary-indep binary-arch
109     .PHONY: build clean binary-indep binary-arch binary install install-indep install-arch